VLANs

De WikiCat IT
Dreceres ràpides: navegació, cerca

Una VLAN serveix per interconnectar xarxes que, a priori, no pertanyen a la mateixa LAN, però que treballaran en la mateixa LAN. És una alternativa a les màscares de subxarxa. Anem a veure un exemple on tenim:

  • Un PC que està en la xarxa 172.17.10.0
  • Un PC que està en la xarxa 172.17.30.0

i que a partir d'una VLAN podran comportar-se com si estiguessin en la mateixa LAN.

Topologia1: VLAN i enrutament de la VLAN

La topologia que farem servir és la següent: Fitxer:M5vlan1.png

Taula de readreçament

A continuació tenim una taula resum de com fer el readreçament:

Dispositiu Interfície Adreça IP Màscara de subxarxa Gateway
Router Fa0/0.10 172.17.10.1 255.255.255.0 N/C
Fa0/0.30 172.17.30.1 255.255.255.0 N/C
PC esquerre NIC 172.17.10.33 255.255.255.0 172.17.10.1
PC dreta NIC 172.17.30.33 255.255.255.0 172.17.30.1

Configuració bàsica

Dos PCs que estan en la mateixa LAN no necessiten cap rooter per veure's. En aquest cas no estan en la mateixa LAN encara que estiguin connectats al mateix router. Per demostrar que els dos PCs no es veuen, primer configurem les IPs i gateways dels PCs i no fem cap configuració del router, i després comprovem la connectivitat dels PCs amb un ping. Com podem veure, el ping del PC de l'esquerra cap al de la dreta falla:

PC>ping 172.17.30.33
Pinging 172.17.30.33 with 32 bytes of data:
Request timed out.
Request timed out.
Request timed out.
Request timed out.
Ping statistics for 172.17.30.33:
Packets: Sent = 4, Received = 0, Lost = 4 (100% loss),

La qual cosa vol dir que necessitem configurar el router per poder tenir els 2 PCs en una LAN virtual.

Agregar VLANs

Creació de la VLAN en els switchs

Tenim dues VLANs: la 10 i la 30. Configurem el switch des de la línia de comandes: (Això s'ha de fer en tots els switchs) Creem les VLANs

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 30

Comprovem que s'han creat les dues VLANs

Switch(config-vlan)#exit
Switch(config)#exit
Switch#
%SYS-5-CONFIG_I: Configured from console by console
Switch#show vlan brief
VLAN Name
Status Ports
---- -------------------------------- --------- -------------------------------
1 default
active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
10 VLAN0010
active
30 VLAN0030
active
1002 fddi-default
active
1003 token-ring-default
active
1004 fddinet-default
active
1005 trnet-default
active 

Assignació d'VLANs a ports

Cada port s'assigna a una VLAN per tal de permetre la comunicació entre VLAN. La interfície Fa0/2 pertany a la VLAN 10 i la interfície Fa0/3 pertany a la VLAN 30. Assignem la VLAN 10 al port Fa0/2

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Assignem la VLAN 30 al port Fa0/3

Switch(config-if)#interface fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30

El port Fa0/1 del switch està definit com a enllaç troncal, la qual cosa li permetrà transmetre informació des de les dues VLANs. Establim el port d'enllaç troncal

Switch(config-if)#interface fa0/1
Switch(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to
up

De moment la comunicació entre LANs encara no és possible.

Configurar l'adreçament IP

Configuració de subinterfícies amb encapsulament 802.1Q.

Hem de crear dues subinterfícies en el Router: Fa0/0.10 i Fa0/0.30. Aquestes subinterfícies s'assignen a les VLANs. Hem de configurar el router des de la línia de comandes: Creació i configuració de la 1a subinterfície

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fa0/0.10
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 172.17.10.1 255.255.255.0

Creació i configuració de la 1a subinterfície

Router(config-subif)#interface fa0/0.30
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 172.17.30.1 255.255.255.0

Ara els resultats del ping han de ser satidfactoris. Comprovem connectivitat:

PC>ping -t 172.17.30.33
Pinging 172.17.30.33 with 32 bytes of data:
Request timed out.
Reply from 172.17.30.33: bytes=32 time=81ms TTL=127
Reply from 172.17.30.33: bytes=32 time=80ms TTL=127
Reply from 172.17.30.33: bytes=32 time=80ms TTL=127
Reply from 172.17.30.33: bytes=32 time=80ms TTL=127
Reply from 172.17.30.33: bytes=32 time=70ms TTL=127
Reply from 172.17.30.33: bytes=32 time=80ms TTL=127
Ping statistics for 172.17.30.33:
Packets: Sent = 7, Received = 6, Lost = 1 (15% loss),
Approximate round trip times in milli-seconds:
Minimum = 70ms, Maximum = 81ms, Average = 78ms
Control-C

Configuració de subinterfícies amb encapsulament 802.1Q.

Hem de crear dues subinterfícies en el Router: Fa0/0.10 i Fa0/0.30. Aquestes subinterfícies s'assignen a les VLANs. Hem de configurar el router des de la línia de comandes: Creació i configuració de la 1a subinterfície

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#interface fa0/0.10
%LINK-5-CHANGED: Interface FastEthernet0/0.10, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.10, changed state to up
Router(config-subif)#encapsulation dot1Q 10
Router(config-subif)#ip address 172.17.10.1 255.255.255.0

Creació i configuració de la 1a subinterfície

Router(config-subif)#interface fa0/0.30
Router(config-subif)#
%LINK-5-CHANGED: Interface FastEthernet0/0.30, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0.30, changed state to up
Router(config-subif)#encapsulation dot1Q 30
Router(config-subif)#ip address 172.17.30.1 255.255.255.0

Ara els resultats del ping han de ser satidfactoris. Comprovem connectivitat:

PC>ping -t 172.17.30.33
Pinging 172.17.30.33 with 32 bytes of data:
Request timed out.
Reply from 172.17.30.33: bytes=32 time=81ms TTL=127
Reply from 172.17.30.33: bytes=32 time=80ms TTL=127
Reply from 172.17.30.33: bytes=32 time=80ms TTL=127
Reply from 172.17.30.33: bytes=32 time=80ms TTL=127
Reply from 172.17.30.33: bytes=32 time=70ms TTL=127
Reply from 172.17.30.33: bytes=32 time=80ms TTL=127
Ping statistics for 172.17.30.33:
Packets: Sent = 7, Received = 6, Lost = 1 (15% loss),
Approximate round trip times in milli-seconds:
Minimum = 70ms, Maximum = 81ms, Average = 78ms
Control-C

Topologia 2

Amb la següent topologia crearem 3 VLANs, de manera que encara que hi hagi una única LAN física, lògicament es comporti com a tres LANs diferents:

m5vlan2.png

Taula de readreçament

A continuació tenim una taula resum de com fer el readreçament:

Dispositiu Interfície Adreça IP Màscara de subxarxa Gateway
Switch Dalt VLAN 99 172.17.99.11 255.255.255.0 N/C
Switch Esquerra VLAN 99 172.17.99.12 255.255.255.0 N/C
Switch Dreta VLAN 99 172.17.99.13 255.255.255.0 N/C
PC1 NIC 172.17.10.21 255.255.255.0 172.17.10.1
PC2 NIC 172.17.20.22 255.255.255.0 172.17.20.1
PC3 NIC 172.17.30.23 255.255.255.0 172.17.30.1
PC4 NIC 172.17.10.24 255.255.255.0 172.17.10.1
PC5 NIC 172.17.20.25 255.255.255.0 172.17.20.1
PC6 NIC 172.17.30.26 255.255.255.0 172.17.30.1

Agregar VLANs

Creació de la VLAN en el switch

Tenim quatre VLANs: la 10, la 20, la 30 i la 99. Configurem el switch des de la línia de comandes: Creem les VLANs

Switch>enable
Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#vlan 10
Switch(config-vlan)#exit
Switch(config)#vlan 20
Switch(config-vlan)#exit
Switch(config)#vlan 30
Switch(config)#vlan 99
Switch(config-vlan)#exit

Comprovem que s'han creat les dues VLANs

show vlan brief
VLAN Name
Status Ports
---- -------------------------------- --------- -------------------------------
1 default
active Fa0/4, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
10 VLAN0010
active Fa0/1
20 VLAN0020
active Fa0/2
30 VLAN0030
active
40 VLAN0040
active Fa0/3
99 VLAN0099
active
1002 fddi-default
active
1003 token-ring-default
active
1004 fddinet-default
active
1005 trnet-default
active 

Assignació d'VLANs a ports

Cada port s'assigna a una VLAN per tal de permetre la comunicació entre VLAN. La interfície Fa0/4 pertany a la VLAN 10, la interfície Fa0/3 a la VLAN 20, la interfície Fa0/2 pertany a la VLAN 30 i la interfíci Fa0/1 pertany a la VLAN 99 (enllaç troncal). Assignem la VLAN 10 al port Fa0/4

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface fa0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 10

Assignem la VLAN 20 al port Fa0/3

Switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Switch(config)#interface fa0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 20

Assignem la VLAN 30 al port Fa0/2

Switch(config-if)#interface fa0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 30

El port Fa0/1 del switch està definit com a enllaç troncal, la qual cosa li permetrà transmetre informació des de les dues VLANs. Establim el port d'enllaç troncal

Switch(config-if)#interface fa0/1
Switch(config-if)#switchport mode trunk
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to down
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to
up

De moment la comunicació entre LANs encara no és possible. Això s'ha de fer per als switchs Esquerra i dreta.

Configurar la VLAN d'administració

Switch esquerra

switch(config)#interface vlan 99
switch(config-if)#ip address 172.17.99.12 255.255.255.0
switch(config-if)#no shutdown

Switch dalt

switch(config)#interface vlan 99
switch(config-if)#ip address 172.17.99.11 255.255.255.0
switch(config-if)#no shutdown

Switch dreta

switch(config)#interface vlan 99
switch(config-if)#ip address 172.17.99.13 255.255.255.0
switch(config-if)#no shutdown

Configurar VLAN nativa per als ports d'enllaç troncal

Switch dalt

switch(config)#interface fa0/1
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk native vlan 99
switch(config-if)#interface fa0/2
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk native vlan 99
switch(config-if)#end

Switch Esquerra

switch(config)#interface fa0/1
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk native vlan 99
switch(config-if)#end

Switch Dreta

switch(config)#interface fa0/1
switch(config-if)#switchport mode trunk
switch(config-if)#switchport trunk native vlan 99
Eines de l'usuari
Espais de noms

Variants
Navegació
Eines