Configruar router cisco amb comandes

De WikiCat IT
Dreceres ràpides: navegació, cerca

Per explicar això, ens basarem amb un exemple. Cal seguir els següents passos:

Preparació

1. Posem un router a l'escenari. En aquest exemple posarem un router PT, que té dos ports FastEthernet per a cable parell trenat, dos ports FastEthernet per a fibra òptica i dos ports serial.

2. Obrim la finestra del router i anem a la pestanya CLI.

3. El router s’inicialitza i ens pregunta si volem continuar amb la configuració. Responem que no (no).

Continue with configuration dialog? [yes/no]: no

4. Premem Enter quan ens surti el següent missatge: Press RETURN to get started!

5 En aquest punt ja tenim el router preparat per configurar-lo amb comandes. Ens ha de sortir la següent línia:

Router>

Veure interfícies

6. Per veure un petit resum de les interfícies que té un router, ho fem amb la comanda

show ip interface brief:
Router>show ip interface brief
Interface
IP-Address
OK? Method Status
Protocol
FastEthernet0/0 unassigned YES unset administratively down down
FastEthernet1/0 unassigned YES unset administratively down down
Serial2/0 unassigned YES unset administratively down down
Serial3/0 unassigned YES unset administratively down down
FastEthernet4/0 unassigned YES unset administratively down down
FastEthernet5/0 unassigned YES unset administratively down down

Com es veu, cap itnerfície no té IP assignada. A més, no estan engedades (down) Aquest pas es pot fer en qualsevol moment del procés, per comprovar que tot està corercte.

Assignació de hostname i secrets

7. Primerament hem d'entrar en mode privilegiat (per defecte estem en mode usuari). Per a fer això cal escriure la comanda enable. Veurem que ens canvia el prefixe:

Router>enable

Router#

8. Seguidament hem d'entrar en mode de configuració global. Per fer això cal escriure la comanda configure terminal. Veurem que el prefix torna a canviar:

Router#configure terminal

Enter configuration commands, one per line. End with CNTL/Z.

Router(config)#

9. Ara ja podem posar el hostname (el nom que li donem al router). En aquest cas li posarem SMX1:

Router(config)#hostname SMX1

SMX1(config)# Com podem veure, s'ha canviat el hostname.

10. Ara posarem un “secret”, que no és més que un password que ens demanarà per poder configurar el router per aquelles opcions que es necessitin privilegis. En aquest cas posarem de secret SMX123:

SMX1(config)#enable secret SMX123
SMX1(config)#

Si no protesta, vol dir que ho ha fet bé.

11. Ara posarem un “password”, que és el mateix que abans, per si no especifiquéssim un secret. Com que no ens deixa posar el mateix password d’abans, posarem SMXSMX:

SMX1(config)#enable password SMXSMX
SMX1(config)#

12. Ara comprovarem que ens demana el secret quan volem entrar en mode privilegiat. Primer hem de sortir del mode configuració global (exit), després del mode privilegiat (exit) fins a estar en mode usuari. Fem el següent:

SMX1>enable

Password: SMX1#

Com podem veure, ens demana el password.

Configuració d'adaptadors

13. Suposem que volem configurar el port FastEthernet 0/0 amb la IP 192.168.3.1 i màscara de subxarxa 255.255.255.0. Huaríem d'executar les següents comandes des del mode configuració global:

SMX1(config)#interface FastEthernet0/0
SMX1(config-if)#ip address 192.168.3.1 255.255.255.0
SMX1(config-if)#no shutdown
SMX1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up

La comanda no shutdown serveix per posar a ON l'interfície. Qualsevol interfície FastEthernet es configura de la mateixa forma.

14. Suposem que volem configurar el port Serial 2/0 amb la IP 10.0.0.1 i màscara de subxarxa 255.0.0.0. A més, volem una velocitat de rellotge de 128000 Huaríem d'executar les següents comandes des del mode configuració global:

SMX1(config)#interface Serial2/0
SMX1(config-if)#ip address 10.0.0.1 255.0.0.0
SMX1(config-if)#clock rate 128000
SMX1(config-if)#no shutdown
%LINK-5-CHANGED: Interface Serial2/0, changed state to down

La comanda clock rate serveix per posar la velocitat del rellotge (en Hz). Qualsevol interfície Serial es configura de la mateixa forma.

Configuració de protocols d'enrutament

15. Suposem que volem afegir la xarxa 192.168.7.0 al router mitjançant el protocol RIP. Ho faríem com segueix:

SMX1(config-if)#router rip
SMX1(config-router)#network 192.168.17.0

Com es pot veure, hem entrat dins del submode de configuració del protocol d'enrutament.

16. Suposem que volem afegir la xarxa 192.168.8.0 al router mitjançant el protocol estàtic.

Suposant que aquesta xarxa la veiéssim a partir de la IP 10.0.0.2, ho faríem com segueix:

SMX1(config)#ip route 192.168.8.0 255.255.255.0 10.0.0.2

Guardar la configuració activa

17. Finalment desem la configuració activa del router, per poder-lo fer servir més endevant o en un alter router. Ho guarda a la NVRAM del router. Cal executar la següent comanda:

SMX1#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]

18. Finalment podem descarergar aquest fitxer. A continuació podem veure el fitxer resultant de la configuració d'aquest router:

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname SMX1
!
!
!
enable secret 5 $1$mERr$TvQV0o96b8Cy3d8ujJ/5D0
enable password SMXSMX
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.3.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/0
no ip address
duplex auto
speed auto
shutdown
!
interface Serial2/0
ip address 10.0.0.1 255.0.0.0
ipv6 ospf cost 781
clock rate 128000
!
interface Serial3/0
no ip address
ipv6 ospf cost 781
shutdown
!
interface FastEthernet4/0
no ip address
shutdown
!
interface FastEthernet5/0
no ip address
shutdown
!
router rip
network 192.168.17.0
!
ip classless
ip route 192.168.8.0 255.255.255.0 10.0.0.2
!
!
!
!
!
!
!
line con 0
line vty 0 4
login
!
!
!
end

Configuar router amb IPv6

Router>enable
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#ipv6 unicast-routing
Router(config)#interface fastethernet 0/0
Router(config-if)#ipv6 enable
Router(config-if)#ipv6 address 2001:0db8:1234::c0a8:401/120
Router(config-if)#no shutdown
Router(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up
Eines de l'usuari
Espais de noms

Variants
Navegació
Eines